Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A small tool to provide detailed information on the hardware \ |
| 2 | configuration of the machine. It can report exact memory configuration, \ |
| 3 | firmware version, mainboard configuration, CPU version and speed, cache \ |
| 4 | configuration, bus speed, etc. on DMI-capable or EFI systems." |
| 5 | SUMMARY = "Hardware lister" |
| 6 | HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter" |
| 7 | SECTION = "console/tools" |
| 8 | |
| 9 | LICENSE = "GPLv2+" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
| 12 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 13 | |
| 14 | SRC_URI = " \ |
| 15 | http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 16 | file://0001-Fix-musl-build.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 18 | SRC_URI[md5sum] = "8c70d46e906688309095c73ecb9396e3" |
| 19 | SRC_URI[sha256sum] = "9bb347ac87142339a366a1759ac845e3dbb337ec000aa1b99b50ac6758a80f80" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/lshw-B.${PV}" |
| 22 | |
| 23 | do_compile() { |
| 24 | # build core only - don't ship gui |
| 25 | oe_runmake -C src core |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | oe_runmake install DESTDIR=${D} |
| 30 | } |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "native" |