blob: 2b5ebcc271c8043e2df45188547cc365876c0913 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Kernel selftest for Linux"
2DESCRIPTION = "Kernel selftest for Linux"
3LICENSE = "GPLv2"
4
5LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
6
7DEPENDS = "rsync-native llvm-native"
8
9# for musl libc
10SRC_URI_append_libc-musl = "\
11 file://userfaultfd.patch \
12 "
13SRC_URI += "file://run-ptest \
14 file://COPYING \
15 "
16
17# now we just test bpf and vm
18# we will append other kernel selftest in the future
19# bpf was added in 4.10 with: https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d
20# if you have older kernel than that you need to remove it from PACKAGECONFIG
Andrew Geissler82c905d2020-04-13 13:39:40 -050021PACKAGECONFIG ??= "bpf firmware vm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022PACKAGECONFIG_remove_x86 = "bpf"
Andrew Geisslerd688a012020-09-18 13:36:00 -050023PACKAGECONFIG_remove_arm = "bpf vm"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024# host ptrace.h is used to compile BPF target but mips ptrace.h is needed
25# progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs'
26# m = PT_REGS_RC(ctx);
Andrew Geisslerd688a012020-09-18 13:36:00 -050027# vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654)
28PACKAGECONFIG_remove_qemumips = "bpf vm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
30PACKAGECONFIG[bpf] = ",,elfutils libcap libcap-ng rsync-native,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031PACKAGECONFIG[firmware] = ",,libcap, bash"
Andrew Geisslerd688a012020-09-18 13:36:00 -050032PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34do_patch[depends] += "virtual/kernel:do_shared_workdir"
35
36inherit linux-kernel-base kernel-arch ptest
37
38S = "${WORKDIR}/${BP}"
39
40TEST_LIST = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 ${@bb.utils.filter('PACKAGECONFIG', 'bpf firmware vm', d)} \
Brad Bishope42b3e32020-01-15 22:08:42 -050042 rtc \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043"
44
45EXTRA_OEMAKE = '\
46 CROSS_COMPILE=${TARGET_PREFIX} \
47 ARCH=${ARCH} \
48 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050049 CLANG="clang -fno-stack-protector -target ${TARGET_ARCH} ${TOOLCHAIN_OPTIONS}" \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080050 AR="${AR}" \
51 LD="${LD}" \
52 DESTDIR="${D}" \
Andrew Geisslerd688a012020-09-18 13:36:00 -050053 MACHINE="${ARCH}" \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054'
55
56KERNEL_SELFTEST_SRC ?= "Makefile \
57 include \
Andrew Geisslerd688a012020-09-18 13:36:00 -050058 kernel \
59 lib \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 tools \
61 scripts \
62 arch \
63 LICENSES \
64"
65
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080066do_compile() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050067 if [ ${@bb.utils.contains('PACKAGECONFIG', 'bpf', 'True', 'False', d)} = 'True' ]; then
Brad Bishop0f291cc2019-09-01 15:16:57 -040068 if [ ${@bb.utils.contains('DEPENDS', 'clang-native', 'True', 'False', d)} = 'False' ]; then
69 bbwarn "clang >= 6.0 with bpf support is needed with kernel 4.18+ so
70either install it and add it to HOSTTOOLS, or add clang-native from meta-clang to dependency"
71 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050072 fi
73
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080074 for i in ${TEST_LIST}
75 do
76 oe_runmake -C ${S}/tools/testing/selftests/${i}
77 done
78}
79
80do_install() {
81 for i in ${TEST_LIST}
82 do
83 oe_runmake -C ${S}/tools/testing/selftests/${i} INSTALL_PATH=${D}/usr/kernel-selftest/${i} install
84 done
85 if [ -e ${D}/usr/kernel-selftest/bpf/test_offload.py ]; then
86 sed -i -e '1s,#!.*python3,#! /usr/bin/env python3,' ${D}/usr/kernel-selftest/bpf/test_offload.py
87 fi
88 chown root:root -R ${D}/usr/kernel-selftest
89}
90
91do_configure() {
92 install -D -m 0644 ${WORKDIR}/COPYING ${S}/COPYING
93}
94
95do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated"
96python copy_kselftest_source_from_kernel() {
97 sources = (d.getVar("KERNEL_SELFTEST_SRC") or "").split()
98 src_dir = d.getVar("STAGING_KERNEL_DIR")
99 dest_dir = d.getVar("S")
100 bb.utils.mkdirhier(dest_dir)
101 for s in sources:
102 src = oe.path.join(src_dir, s)
103 dest = oe.path.join(dest_dir, s)
104 if os.path.isdir(src):
105 oe.path.copytree(src, dest)
106 else:
107 bb.utils.copyfile(src, dest)
108}
109
110remove_unrelated() {
111 if ${@bb.utils.contains('PACKAGECONFIG','bpf','true','false',d)} ; then
112 test -f ${S}/tools/testing/selftests/bpf/Makefile && \
113 sed -i -e 's/test_pkt_access.*$/\\/' \
114 -e 's/test_pkt_md_access.*$/\\/' \
115 -e 's/sockmap_verdict_prog.*$/\\/' \
116 ${S}/tools/testing/selftests/bpf/Makefile || \
117 bberror "Your kernel is probably older than 4.10 and doesn't have tools/testing/selftests/bpf/Makefile file from https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d, disable bpf PACKAGECONFIG"
118 fi
119}
120
121PACKAGE_ARCH = "${MACHINE_ARCH}"
122
123INHIBIT_PACKAGE_DEBUG_SPLIT="1"
124FILES_${PN} += "/usr/kernel-selftest"
125
126RDEPENDS_${PN} += "python3"
127# tools/testing/selftests/vm/Makefile doesn't respect LDFLAGS and tools/testing/selftests/Makefile explicitly overrides to empty
128INSANE_SKIP_${PN} += "ldflags"
Brad Bishop26bdd442019-08-16 17:08:17 -0400129
Brad Bishop0f291cc2019-09-01 15:16:57 -0400130SECURITY_CFLAGS = ""
Brad Bishop5f78ea12019-09-10 07:20:03 -0400131COMPATIBLE_HOST_libc-musl = 'null'
132
Brad Bishopdec060e2019-09-23 08:01:31 -0400133# It has native clang/llvm dependency, poky distro is reluctant to include them as deps
134# this helps with world builds on AB
135EXCLUDE_FROM_WORLD = "1"
136