Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require libgpiod.inc |
| 2 | |
| 3 | DEPENDS += "autoconf-archive-native" |
| 4 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 5 | SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112" |
| 6 | SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | |
| 8 | # enable cxx bindings |
| 9 | PACKAGECONFIG ?= "cxx" |
| 10 | |
| 11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
| 12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
| 13 | |
| 14 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
| 15 | |
| 16 | inherit python3native |
| 17 | |
| 18 | PACKAGES =+ "${PN}-python" |
| 19 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 20 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 21 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |