Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Timing analysis tools for suspend/resume/boot" |
| 2 | DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \ |
| 3 | in optimizing their linux stack's suspend/resume & boot time." |
| 4 | HOMEPAGE = "https://01.org/pm-graph" |
| 5 | LICENSE = "GPL-2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 7 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 8 | SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 9 | SRC_URI = "git://github.com/intel/pm-graph.git \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | file://0001-Makefile-fix-multilib-build-failure.patch \ |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 11 | file://0001-sleepgraph.py-use-python3.patch \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 12 | file://0001-sleepgraph-add-support-for-RT-kernel-ftrace-flags.patch \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 13 | file://0001-sleepgraph.py-parse-unfished-cpu-exec-line.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 14 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | # Apart from the listed RDEPENDS, analyze-suspend depends on some features |
| 18 | # provided by the kernel. These options are: |
| 19 | # - CONFIG_PM_DEBUG=y |
| 20 | # - CONFIG_PM_SLEEP_DEBUG=y |
| 21 | # - CONFIG_FTRACE=y |
| 22 | # - CONFIG_FUNCTION_TRACER=y |
| 23 | # - CONFIG_FUNCTION_GRAPH_TRACER=y |
| 24 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | COMPATIBLE_HOST='(i.86|x86_64).*' |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 26 | EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | |
| 28 | do_install() { |
| 29 | oe_runmake install |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | } |
| 32 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 33 | RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | RPROVIDES_${PN} = "analyze-suspend" |
| 35 | BBCLASSEXTEND = "native nativesdk" |