Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Helper application and MIME type associations for file types" |
| 2 | HOMEPAGE = "https://pagure.io/mailcap" |
| 3 | DESCRIPTION = "The mailcap file is used by the metamail program. Metamail reads the \ |
| 4 | mailcap file to determine how it should display non-text or multimedia \ |
| 5 | material. Basically, mailcap associates a particular type of file \ |
| 6 | with a particular program that a mail agent or other program can call \ |
| 7 | in order to handle the file. Mailcap should be installed to allow \ |
| 8 | certain programs to be able to handle non-text files. \ |
| 9 | \ |
| 10 | Also included in this package is the mime.types file which contains a \ |
| 11 | list of MIME types and their filename extension associations, used \ |
| 12 | by several applications e.g. to determine MIME types for filenames." |
| 13 | |
| 14 | SECTION = "System Environment/Base" |
| 15 | |
| 16 | LICENSE = "PD & MIT" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 17 | LIC_FILES_CHKSUM = "file://COPYING;md5=8dce08227d135cfda1f19d4c0c6689de" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | |
| 19 | SRC_URI = "https://releases.pagure.org/${BPN}/${BP}.tar.xz" |
| 20 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 21 | SRC_URI[md5sum] = "ee02da867389d290923cc138487176f9" |
| 22 | SRC_URI[sha256sum] = "5eea2ef17b304977ba3ecb87afad4319fa0440f825e4f6fba6e8fa2ffeb88785" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 24 | inherit update-alternatives |
| 25 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | do_install() { |
| 27 | oe_runmake install DESTDIR=${D} sysconfdir=${sysconfdir} mandir=${mandir} |
| 28 | } |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 29 | |
| 30 | ALTERNATIVE_${PN} = "mime.types" |
| 31 | ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types" |