blob: a09bc240d331e597fc6c89c3204ac6d4526be228 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001inherit python3native
2
3DEPENDS_append = " meson-native ninja-native"
4
5# As Meson enforces out-of-tree builds we can just use cleandirs
6B = "${WORKDIR}/build"
7do_configure[cleandirs] = "${B}"
8
9# Where the meson.build build configuration is
10MESON_SOURCEPATH = "${S}"
11
12# These variables in the environment override the *native* tools, not the cross.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013export CPPFLAGS = "${BUILD_CPPFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014export CC = "${BUILD_CC}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015export CFLAGS = "${BUILD_CFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016export CXX = "${BUILD_CXX}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017export CXXFLAGS = "${BUILD_CXXFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018export LD = "${BUILD_LD}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019export LDFLAGS = "${BUILD_LDFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020export AR = "${BUILD_AR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021export PKG_CONFIG = "pkg-config-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
23def noprefix(var, d):
24 return d.getVar(var, True).replace(d.getVar('prefix', True) + '/', '', 1)
25
26MESONOPTS = " --prefix ${prefix} \
27 --bindir ${@noprefix('bindir', d)} \
28 --sbindir ${@noprefix('sbindir', d)} \
29 --datadir ${@noprefix('datadir', d)} \
30 --libdir ${@noprefix('libdir', d)} \
31 --libexecdir ${@noprefix('libexecdir', d)} \
32 --includedir ${@noprefix('includedir', d)} \
33 --mandir ${@noprefix('mandir', d)} \
34 --infodir ${@noprefix('infodir', d)} \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035 --sysconfdir ${sysconfdir} \
36 --localstatedir ${localstatedir} \
37 --sharedstatedir ${sharedstatedir}"
38
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039MESON_C_ARGS = "${TARGET_CC_ARCH}${TOOLCHAIN_OPTIONS}"
40MESON_LINK_ARGS = "${MESON_C_ARGS} ${LDFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041
42MESON_HOST_ENDIAN = "${@bb.utils.contains('SITEINFO_ENDIANNESS', 'be', 'big', 'little', d)}"
43MESON_TARGET_ENDIAN = "${@bb.utils.contains('TUNE_FEATURES', 'bigendian', 'big', 'little', d)}"
44
45EXTRA_OEMESON += "${PACKAGECONFIG_CONFARGS}"
46
47MESON_CROSS_FILE = ""
48MESON_CROSS_FILE_class-target = "--cross-file ${WORKDIR}/meson.cross"
49
50def meson_array(var, d):
51 return "', '".join(d.getVar(var, True).split()).join(("'", "'"))
52
53addtask write_config before do_configure
54do_write_config[vardeps] += "MESON_C_ARGS TOOLCHAIN_OPTIONS"
55do_write_config() {
56 # This needs to be Py to split the args into single-element lists
57 cat >${WORKDIR}/meson.cross <<EOF
58[binaries]
59c = '${HOST_PREFIX}gcc'
60cpp = '${HOST_PREFIX}g++'
61ar = '${HOST_PREFIX}ar'
62ld = '${HOST_PREFIX}ld'
63strip = '${HOST_PREFIX}strip'
64readelf = '${HOST_PREFIX}readelf'
65pkgconfig = 'pkg-config'
66
67[properties]
Brad Bishopd7bf8c12018-02-25 22:55:05 -050068needs_exe_wrapper = true
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069c_args = [${@meson_array('MESON_C_ARGS', d)}]
Brad Bishopd7bf8c12018-02-25 22:55:05 -050070c_link_args = [${@meson_array('MESON_LINK_ARGS', d)}]
71cpp_args = [${@meson_array('MESON_C_ARGS', d)}]
72cpp_link_args = [${@meson_array('MESON_LINK_ARGS', d)}]
Brad Bishop6e60e8b2018-02-01 10:27:11 -050073
74[host_machine]
75system = '${HOST_OS}'
76cpu_family = '${HOST_ARCH}'
77cpu = '${HOST_ARCH}'
78endian = '${MESON_HOST_ENDIAN}'
79
80[target_machine]
81system = '${TARGET_OS}'
82cpu_family = '${TARGET_ARCH}'
83cpu = '${TARGET_ARCH}'
84endian = '${MESON_TARGET_ENDIAN}'
85EOF
86}
87
88CONFIGURE_FILES = "meson.build"
89
90meson_do_configure() {
91 if ! meson ${MESONOPTS} "${MESON_SOURCEPATH}" "${B}" ${MESON_CROSS_FILE} ${EXTRA_OEMESON}; then
92 cat ${B}/meson-logs/meson-log.txt
93 bbfatal_log meson failed
94 fi
95}
96
97do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
98meson_do_compile() {
99 ninja ${PARALLEL_MAKE}
100}
101
102meson_do_install() {
103 DESTDIR='${D}' ninja ${PARALLEL_MAKEINST} install
104}
105
106EXPORT_FUNCTIONS do_configure do_compile do_install