Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Optimised Inner Loop Runtime Compiler" |
| 2 | HOMEPAGE = "http://code.entropywave.com/projects/orc/" |
| 3 | LICENSE = "BSD-2-Clause & BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e" |
| 5 | |
| 6 | SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz;name=orc" |
| 7 | SRC_URI[orc.md5sum] = "72e0612ace54d77aa2f7a006348ee81a" |
| 8 | SRC_URI[orc.sha256sum] = "767eaebce2941737b43368225ec54598b3055ca78b4dc50c4092f5fcdc0bdfe7" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | |
| 12 | BBCLASSEXTEND = "native nativesdk" |
| 13 | |
| 14 | PACKAGES =+ "orc-examples" |
| 15 | FILES_orc-examples = "${libdir}/orc/*" |
| 16 | FILES_${PN} = "${bindir}/*" |
| 17 | |
| 18 | python populate_packages_prepend () { |
| 19 | libdir = d.expand('${libdir}') |
| 20 | do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True) |
| 21 | } |
| 22 | |
| 23 | do_compile_prepend_class-native () { |
| 24 | sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c |
| 25 | } |