Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "EDK2 Test Parser" |
| 2 | DESCRIPTION = "EDK2 Test Parser for parsing the results of UEFI SCT tests" |
| 3 | HOMEPAGE = "https://gitlab.arm.com/systemready/edk2-test-parser" |
| 4 | |
| 5 | inherit native |
| 6 | |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c0550be4b3b9c0223efd0eaa70dc9085" |
| 9 | |
| 10 | RDEPENDS:${PN} = "python3-packaging-native python3-pyyaml-native \ |
| 11 | python3-jsonschema-native" |
| 12 | |
| 13 | PV = "v2023.04" |
| 14 | S = "${WORKDIR}/git" |
| 15 | SRC_URI = "git://git.gitlab.arm.com/systemready/edk2-test-parser.git;protocol=https;nobranch=1" |
| 16 | |
| 17 | # The SRCREV is at the v2023.04 tag |
| 18 | SRCREV = "e8cdb692592d2a152cb87cf4d9fbd7ba2ae8b405" |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}/${libdir}/edk2_test_parser |
| 22 | cp -r ${S}/* ${D}/${libdir}/edk2_test_parser |
| 23 | } |
| 24 | |
| 25 | do_configure[noexec] = "1" |
| 26 | do_compile[noexec] = "1" |