blob: 27ebd639496e24656c61c7e94532e816a27bf504 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
2
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
5
6SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main"
7
8SRCREV = "bdd6d6fc150d53d89658bebbfa73a7bfd9a89cb4"
9S = "${WORKDIR}/git"
10
11DEPENDS = "zstd"
12DEPENDS:append:libc-musl = " argp-standalone"
13
14inherit meson pkgconfig lib_package
15
16PACKAGECONFIG ??= "openssl zckdl"
17
18# zckdl gets packaged into zchunk-bin
19PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl"
20# Use OpenSSL primitives for SHA
21PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl"
22
23BBCLASSEXTEND = "native nativesdk"