blob: e4555af6d5979225271ee6f7f645aa78b9958cfd [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9SRCREV = "23cc2d78fd4f866b6ab527886a396bec36948605"
10SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
11 file://0001-cmake-disable-building-external-dependencies.patch \
12 file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
13 file://0001-CMakeLists.txt-drop-OSDependent-OGLCompiler-from-lis.patch \
14 "
15UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
16S = "${WORKDIR}/git"
17
18inherit cmake python3native pkgconfig
19
20DEPENDS = "spirv-headers spirv-tools glslang"
21
22EXTRA_OECMAKE = " \
23 -DCMAKE_BUILD_TYPE=Release \
24 -DBUILD_EXTERNAL=OFF \
25 -DSHADERC_SKIP_TESTS=ON \
26 -DSHADERC_SKIP_EXAMPLES=ON \
27 -DSHADERC_SKIP_COPYRIGHT_CHECK=ON \
28"
29
30BBCLASSEXTEND = "native nativesdk"