Jordan Chang | 7cbff67 | 2023-03-03 15:53:28 +0800 | [diff] [blame] | 1 | SUMMARY = "OpenBMC NCPLite Front Panel LED Monitor" |
| 2 | DESCRIPTION = "OpenBMC NCPLite Front Panel Monitor" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 8 | |
| 9 | inherit systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | RDEPENDS:${PN} += "bash" |
| 13 | |
| 14 | SRC_URI += " file://ncplite-led.sh \ |
| 15 | file://ncplite-led.service \ |
| 16 | " |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${libexecdir}/{BPN} |
| 20 | install -m 0755 ${WORKDIR}/ncplite-led.sh ${D}${libexecdir}/{BPN} |
| 21 | |
| 22 | install -d ${D}${systemd_system_unitdir} |
| 23 | install -m 0644 ${WORKDIR}/ncplite-led.service ${D}${systemd_system_unitdir} |
| 24 | } |
| 25 | |
| 26 | SYSTEMD_PACKAGES = "${PN}" |
| 27 | SYSTEMD_SERVICE:${PN} = "ncplite-led.service" |