Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame^] | 1 | BUILD_GOOS = "${@go_map_os(d.getVar('BUILD_OS', True), d)}" |
| 2 | BUILD_GOARCH = "${@go_map_arch(d.getVar('BUILD_ARCH', True), d)}" |
| 3 | BUILD_GOTUPLE = "${BUILD_GOOS}_${BUILD_GOARCH}" |
| 4 | HOST_GOOS = "${@go_map_os(d.getVar('HOST_OS', True), d)}" |
| 5 | HOST_GOARCH = "${@go_map_arch(d.getVar('HOST_ARCH', True), d)}" |
| 6 | HOST_GOARM = "${@go_map_arm(d.getVar('HOST_ARCH', True), d.getVar('TUNE_FEATURES', True), d)}" |
| 7 | HOST_GOTUPLE = "${HOST_GOOS}_${HOST_GOARCH}" |
| 8 | TARGET_GOOS = "${@go_map_os(d.getVar('TARGET_OS', True), d)}" |
| 9 | TARGET_GOARCH = "${@go_map_arch(d.getVar('TARGET_ARCH', True), d)}" |
| 10 | TARGET_GOARM = "${@go_map_arm(d.getVar('TARGET_ARCH', True), d.getVar('TUNE_FEATURES', True), d)}" |
| 11 | TARGET_GOTUPLE = "${TARGET_GOOS}_${TARGET_GOARCH}" |
| 12 | GO_BUILD_BINDIR = "${@['bin/${HOST_GOTUPLE}','bin'][d.getVar('BUILD_GOTUPLE',True) == d.getVar('HOST_GOTUPLE',True)]}" |
| 13 | |
| 14 | def go_map_arch(a, d): |
| 15 | import re |
| 16 | if re.match('i.86', a): |
| 17 | return '386' |
| 18 | elif a == 'x86_64': |
| 19 | return 'amd64' |
| 20 | elif re.match('arm.*', a): |
| 21 | return 'arm' |
| 22 | elif re.match('aarch64.*', a): |
| 23 | return 'arm64' |
| 24 | elif re.match('p(pc|owerpc)(|64)', a): |
| 25 | return 'powerpc' |
| 26 | else: |
| 27 | bb.error("cannot map '%s' to a Go architecture" % a) |
| 28 | |
| 29 | def go_map_arm(a, f, d): |
| 30 | import re |
| 31 | if re.match('arm.*', a) and re.match('arm.*7.*', f): |
| 32 | return '7' |
| 33 | return '' |
| 34 | |
| 35 | def go_map_os(o, d): |
| 36 | if o.startswith('linux'): |
| 37 | return 'linux' |
| 38 | return o |