blob: 0d03ebef8487d9a9b69f0a9d818266029662a109 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001SUMMARY = "protobuf-c"
2DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C"
3HOMEPAGE = "http://code.google.com/p/protobuf-c/"
4SECTION = "console/tools"
5LICENSE = "Apache-2.0"
6
7LIC_FILES_CHKSUM = "file://protobuf-c/protobuf-c.c;endline=28;md5=0feb44cc63eacef97219b0174967492f"
8
9COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
10
11DEPENDS = "protobuf protobuf-c-native"
12
13SRC_URI[md5sum] = "41d437677ea16f9d3611d98841c4af3b"
14SRC_URI[sha256sum] = "09c5bb187b7a8e86bc0ff860f7df86370be9e8661cdb99c1072dcdab0763562c"
15SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.1.1/protobuf-c-1.1.1.tar.gz "
16SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch"
17
18inherit autotools pkgconfig
19
20BBCLASSEXTEND = "native nativesdk"
21
22do_configure_prepend_class-target() {
23 export PKG_CONFIG_PATH="${STAGING_LIBDIR_NATIVE}/pkgconfig:${PKG_CONFIG_PATH}"
24}
25
26do_install_append_class-native() {
27 install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir}
28}