Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame^] | 1 | SUMMARY = "protobuf-c" |
| 2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" |
| 3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" |
| 4 | SECTION = "console/tools" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://protobuf-c/protobuf-c.c;endline=28;md5=0feb44cc63eacef97219b0174967492f" |
| 8 | |
| 9 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" |
| 10 | |
| 11 | DEPENDS = "protobuf protobuf-c-native" |
| 12 | |
| 13 | SRC_URI[md5sum] = "41d437677ea16f9d3611d98841c4af3b" |
| 14 | SRC_URI[sha256sum] = "09c5bb187b7a8e86bc0ff860f7df86370be9e8661cdb99c1072dcdab0763562c" |
| 15 | SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.1.1/protobuf-c-1.1.1.tar.gz " |
| 16 | SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch" |
| 17 | |
| 18 | inherit autotools pkgconfig |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | do_configure_prepend_class-target() { |
| 23 | export PKG_CONFIG_PATH="${STAGING_LIBDIR_NATIVE}/pkgconfig:${PKG_CONFIG_PATH}" |
| 24 | } |
| 25 | |
| 26 | do_install_append_class-native() { |
| 27 | install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir} |
| 28 | } |