Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Yet Another V4L2 Test Application" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | |
| 5 | SRC_URI = "git://git.ideasonboard.org/yavta.git \ |
| 6 | file://0001-Add-stdout-mode-to-allow-streaming-over-the-network-.patch" |
| 7 | SRCREV = "7e9f28bedc1ed3205fb5164f686aea96f27a0de2" |
| 8 | |
| 9 | PV = "0.0" |
| 10 | PR = "r2" |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 14 | |
| 15 | # The yavta sources include copies of the headers required to build in the |
| 16 | # include directory. The Makefile uses CFLAGS to include these, but since |
| 17 | # we override the CFLAGS then we need to add this include path back in. |
| 18 | CFLAGS += "-I${S}/include" |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${bindir} |
| 22 | install -m 0755 yavta ${D}${bindir} |
| 23 | } |
| 24 | |
| 25 | |