blob: 3c157570ee0a229fb758bf36a9dad7c7507324a1 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DEPENDS += " \
14 autoconf-archive-native \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 sdbusplus \
18 "
19
20RDEPENDS_${PN} += " \
21 mtd-utils-ubifs \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 sdbusplus \
25 "
26
Adriana Kobylak2e950822017-06-02 09:22:40 -050027S = "${WORKDIR}/git"
28
29SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
30
Adriana Kobylake2538382017-07-06 10:31:59 -050031SRC_URI += "file://obmc-flash-bios"
Adriana Kobylak69d3de02017-05-25 15:48:27 -050032
Patrick Williams1f259802017-08-02 05:50:03 -050033SRCREV = "1cb127fbc5c34ec8f1e61c8800985db36f50ae8b"
Adriana Kobylak2e950822017-06-02 09:22:40 -050034
35do_install_append() {
Adriana Kobylak69d3de02017-05-25 15:48:27 -050036 install -d ${D}${sbindir}
Adriana Kobylake2538382017-07-06 10:31:59 -050037 install -m 0755 ${WORKDIR}/obmc-flash-bios ${D}${sbindir}/obmc-flash-bios
Adriana Kobylak69d3de02017-05-25 15:48:27 -050038}
39
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050040DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
Adriana Kobylak2e950822017-06-02 09:22:40 -050041
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050042SYSTEMD_SERVICE_${PN} += " \
43 obmc-flash-bios-ubiattach.service \
44 obmc-flash-bios-ubimount@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050045 obmc-flash-bios-ubiumount-prsv.service \
Saqib Khan6316a542017-07-29 11:27:27 -050046 obmc-flash-bios-ubiumount-ro@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050047 obmc-flash-bios-ubiumount-rw@.service \
Adriana Kobylakd8b85752017-07-12 13:52:22 -050048 obmc-flash-bios-ubipatch.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050049 obmc-flash-bios-squashfsmount@.service \
Saqib Khanbea768c2017-07-26 23:48:20 -050050 obmc-flash-bios-ubiremount.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050051 "