Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5" |
| 9 | |
| 10 | SRC_URI = "ftp://invisible-island.net/diffstat/diffstat-${PV}.tgz \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "c048a32d55d8bd6724f382baf41f325f" |
| 15 | SRC_URI[sha256sum] = "25359e0c27183f997b36c9202583b5dc2df390c20e22a92606af4bf7856a55ee" |
| 16 | |
| 17 | S = "${WORKDIR}/diffstat-${PV}" |
| 18 | |
| 19 | inherit autotools gettext ptest |
| 20 | |
| 21 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| 22 | |
| 23 | do_configure () { |
| 24 | if [ ! -e ${S}/acinclude.m4 ]; then |
| 25 | mv ${S}/aclocal.m4 ${S}/acinclude.m4 |
| 26 | fi |
| 27 | autotools_do_configure |
| 28 | } |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 32 | } |