Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame] | 1 | SUMMARY = "Intel ASL compiler/decompiler" |
| 2 | DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)" |
| 3 | HOMEPAGE = "http://www.acpica.org/" |
| 4 | LICENSE = "Intel-ACPI" |
| 5 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompiler.h;beginline=7;endline=114;md5=09f82edcd148ab4c8aa554bc3e9d0676" |
| 6 | SECTION = "console/tools" |
| 7 | |
| 8 | DEPENDS = "bison-native flex-native" |
| 9 | |
| 10 | SRC_URI = "https://www.acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz \ |
| 11 | file://iasl.1 \ |
| 12 | file://Make-CC-definition-conditional.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "be677fc358de9dadc036e1ea678a101b" |
| 16 | SRC_URI[sha256sum] = "6b681732624de1eb58b2bcf1c7ef0744ba14ed35fcaa534d4421574782fbb848" |
| 17 | |
| 18 | S = "${WORKDIR}/acpica-unix-${PV}/" |
| 19 | |
| 20 | BBCLASSEXTEND = "native" |
| 21 | CFLAGS += "-D_LINUX -DACPI_ASL_COMPILER -I../include -I../compiler" |
| 22 | |
| 23 | COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" |
| 24 | |
| 25 | # By setting NOOPT we suppress forcing -O2 and setting _FORTIFY_SOURCE=2. Let the |
| 26 | # optimization and security cflags set them. |
| 27 | # |
| 28 | do_compile() { |
| 29 | oe_runmake iasl NOOPT=TRUE NOFORTIFY=TRUE |
| 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${bindir} ${D}${mandir}/man1 |
| 34 | install -m 0755 ${S}/generate/unix/bin/iasl ${D}${bindir} |
| 35 | install -m 0644 ${WORKDIR}/iasl.1 ${D}${mandir}/man1 |
| 36 | } |