blob: 45856774403671c0cf65bb712afba58b11b49eb7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \
8 "
9LDSHARED += "-pthread"
10
Patrick Williamsda295312023-12-05 16:48:56 -060011SRC_URI[sha256sum] = "13f93ce9bea8016c253b34afc6bd6a75993e5c40672ed5405a9c832f0d4a00bc"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060012
13SRC_URI += "file://0001-pyproject.toml-remove-benchmark-disable-option.patch \
14 file://0001-Fix-include-directory-when-cross-compiling-9129.patch \
15 file://check-memfree.py \
16 file://run-ptest \
17 "
18
19require ${BPN}-crates.inc
20
21inherit pypi python_setuptools3_rust cargo-update-recipe-crates pkgconfig
22
23DEPENDS += " \
24 ${PYTHON_PN}-cffi-native \
25"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-cffi \
29"
30
31RDEPENDS:${PN}:append:class-target = " \
32 ${PYTHON_PN}-numbers \
33 ${PYTHON_PN}-threading \
34"
35
36RDEPENDS:${PN}-ptest += " \
37 ${PYTHON_PN}-bcrypt \
38 ${PYTHON_PN}-cryptography-vectors (= ${PV}) \
39 ${PYTHON_PN}-hypothesis \
40 ${PYTHON_PN}-iso8601 \
41 ${PYTHON_PN}-pretend \
42 ${PYTHON_PN}-psutil \
43 ${PYTHON_PN}-pytest \
44 ${PYTHON_PN}-unittest-automake-output \
45 ${PYTHON_PN}-pytest-subtests \
46 ${PYTHON_PN}-pytz \
47"
48
49inherit ptest
50
51do_install_ptest() {
52 install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
53 install -d ${D}${PTEST_PATH}/tests
54 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
55 # remove test_x509.py as it needs benchmark and we don't
56 # want to introduce the benchmark dependency
57 rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
58 install -d ${D}${PTEST_PATH}/tests/hazmat
59 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
60 cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/
61}
62
63FILES:${PN}-ptest += " \
64 ${PTEST_PATH}/check-memfree.py \
65"
66FILES:${PN}-dbg += " \
67 ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \
68"
69
70BBCLASSEXTEND = "native nativesdk"