Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| 2 | HOMEPAGE = "https://numpy.org/" |
| 3 | DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a752eb20459cf74a9d84ee4825e8317c" |
| 7 | |
| 8 | SRCNAME = "numpy" |
| 9 | |
| 10 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| 11 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| 12 | file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| 13 | file://fix_reproducibility.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "f65738447676ab5777f11e6bbbdb8ce11b785e105f690bc45966574816b6d3ea" |
| 17 | |
| 18 | GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases" |
| 19 | UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$" |
| 20 | |
| 21 | DEPENDS += "python3-cython-native" |
| 22 | |
| 23 | inherit ptest setuptools3 github-releases |
| 24 | |
| 25 | S = "${WORKDIR}/numpy-${PV}" |
| 26 | |
| 27 | CLEANBROKEN = "1" |
| 28 | |
| 29 | do_compile:prepend() { |
| 30 | export NPY_DISABLE_SVML=1 |
| 31 | } |
| 32 | |
| 33 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
| 34 | |
| 35 | # install what is needed for numpy.test() |
| 36 | RDEPENDS:${PN} = "${PYTHON_PN}-unittest \ |
| 37 | ${PYTHON_PN}-difflib \ |
| 38 | ${PYTHON_PN}-pprint \ |
| 39 | ${PYTHON_PN}-pickle \ |
| 40 | ${PYTHON_PN}-shell \ |
| 41 | ${PYTHON_PN}-doctest \ |
| 42 | ${PYTHON_PN}-datetime \ |
| 43 | ${PYTHON_PN}-distutils \ |
| 44 | ${PYTHON_PN}-misc \ |
| 45 | ${PYTHON_PN}-mmap \ |
| 46 | ${PYTHON_PN}-netclient \ |
| 47 | ${PYTHON_PN}-numbers \ |
| 48 | ${PYTHON_PN}-pydoc \ |
| 49 | ${PYTHON_PN}-pkgutil \ |
| 50 | ${PYTHON_PN}-email \ |
| 51 | ${PYTHON_PN}-compression \ |
| 52 | ${PYTHON_PN}-ctypes \ |
| 53 | ${PYTHON_PN}-threading \ |
| 54 | ${PYTHON_PN}-multiprocessing \ |
| 55 | ${PYTHON_PN}-json \ |
| 56 | " |
| 57 | RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \ |
| 58 | ${PYTHON_PN}-hypothesis \ |
| 59 | ${PYTHON_PN}-sortedcontainers \ |
| 60 | ${PYTHON_PN}-resource \ |
| 61 | ${PYTHON_PN}-typing-extensions \ |
| 62 | ldd \ |
| 63 | " |
| 64 | |
| 65 | BBCLASSEXTEND = "native nativesdk" |