blob: d60c0f319031e6c5a80baa21bb03e491778ca03b [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
Andrew Geisslerc5535c92023-01-27 16:10:19 -06008SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=main;protocol=https;lfs=0 \
Andrew Geissler5082cc72023-09-11 08:41:39 -04009 file://0001-vulkan-samples-Fix-reproducibility-issue.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060010 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060011 file://0001-Deprecate-u8string_view.patch;patchdir=third_party/spdlog \
Patrick Williamsb542dec2023-06-09 01:26:37 -050012 file://32bit.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060013 "
14
15UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler028142b2023-05-05 11:29:21 -050016SRCREV = "2307c3eb5608cb1205fa3514b3a31dbfb857d00c"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017
18UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
22
23inherit cmake features_check
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026
27#
28# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
29# used for logging with LOGE in the code. We need to make this match the value we use
30# in the debug source remapping from CFLAGS
31#
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=${TARGET_DBGSRC_DIR}/"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060033# Binaries built with PCH enabled don't appear reproducible, differing results were seen
34# from some builds depending on the point the PCH was compiled. Disable it to be
35# deterministic
36EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050037
38# This needs to be specified explicitly to avoid xcb/xlib dependencies
39EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"