Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Vulkan Utility Libraries" |
| 2 | DESCRIPTION = "Common libraries created to share code across various \ |
| 3 | Vulkan repositories, solving long standing issues for Vulkan SDK \ |
| 4 | developers and users." |
| 5 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 6 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Utility-Libraries" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=4ca2d6799091aaa98a8520f1b793939b" |
| 11 | |
| 12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Utility-Libraries.git;branch=main;protocol=https" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 13 | SRCREV = "4cfc176e3242b4dbdfd3f6c5680c5d8f2cb7db45" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "vulkan" |
| 18 | |
| 19 | DEPENDS = "vulkan-headers" |
| 20 | |
| 21 | EXTRA_OECMAKE = "\ |
| 22 | -DBUILD_TESTS=OFF \ |
| 23 | " |
| 24 | |
| 25 | inherit cmake features_check pkgconfig |
| 26 | |
| 27 | # These recipes need to be updated in lockstep with each other: |
| 28 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, |
| 29 | # vulkan-validation-layers, spirv-headers, spirv-tools, |
| 30 | # vulkan-utility-libraries. |
| 31 | # The tags versions should always be sdk-x.y.z, as this is what |
| 32 | # upstream considers a release. |
| 33 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |