blob: c98d4abf7f95d99a8f6fd75b8ba5955103cb8093 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001DESCRIPTION = "TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU), TCTI Loader (TCTILdr), TCTIs, policy, and RC Decoding (rcdecode) libraries"
2HOMEPAGE = "https://github.com/tpm2-software/tpm2-pytss"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
5
6SRC_URI[sha256sum] = "5b5b4b1456fdc1aeef3d2c3970beaa078c8f7f2648c97a69bcf60c5a2f95c897"
7
8PYPI_PACKAGE = "tpm2-pytss"
9
10DEPENDS = "python3-pkgconfig-native python3-pycparser-native python3-asn1crypto-native"
11DEPENDS:append = " python3-cryptography-native tpm2-tss"
12
13inherit autotools pkgconfig pypi setuptools3_legacy
14
15RDEPENDS:${PN} = "libtss2"