blob: b346cc85d9ea8e47917e28ece29452e14f5c5915 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
Andrew Geissler8f840682023-07-21 09:09:43 -05006SRC_URI[sha256sum] = "af598ed32d6ae86f1b747b82783958b1a4ab8f617b06fe68795c7f026abbdcad"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "MarkupSafe"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05009inherit pypi setuptools3 ptest
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11RDEPENDS:${PN} += "${PYTHON_PN}-stringold"
12
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050021 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000022"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}