Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | # Copyright (C) 2013 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Library of utility functions from BSD systems" |
| 5 | DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \ |
| 6 | and lacking on others like GNU systems, thus making it easier to port \ |
| 7 | projects with strong BSD origins, without needing to embed the same \ |
| 8 | code over and over again on each project." |
| 9 | |
| 10 | HOMEPAGE = "https://libbsd.freedesktop.org/wiki/" |
| 11 | # There seems to be more licenses used in the code, I don't think we want to list them all here, complete list: |
| 12 | # OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u |
| 13 | # License: BSD-2-clause |
| 14 | # License: BSD-2-clause-NetBSD |
| 15 | # License: BSD-2-clause-author |
| 16 | # License: BSD-2-clause-verbatim |
| 17 | # License: BSD-3-clause |
| 18 | # License: BSD-3-clause-author |
| 19 | # License: BSD-3-clause-John-Birrell |
| 20 | # License: BSD-3-clause-Regents |
| 21 | # License: BSD-4-clause-Christopher-G-Demetriou |
| 22 | # License: BSD-4-clause-Niels-Provos |
| 23 | # License: BSD-5-clause-Peter-Wemm |
| 24 | # License: Beerware |
| 25 | # License: Expat |
| 26 | # License: ISC |
| 27 | # License: ISC-Original |
| 28 | # License: public-domain |
| 29 | # License: public-domain-Colin-Plumb |
| 30 | LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD" |
| 31 | LICENSE:${PN} = "BSD-3-Clause & ISC & PD" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 32 | LICENSE:${PN}-dbg = "BSD-3-Clause & ISC & PD" |
| 33 | LICENSE:${PN}-dev = "BSD-3-Clause & ISC & PD" |
| 34 | LICENSE:${PN}-doc = "BSD-3-Clause & BSD-4-Clause & ISC & PD" |
| 35 | LICENSE:${PN}-locale = "BSD-3-Clause & ISC & PD" |
| 36 | LICENSE:${PN}-src = "BSD-3-Clause & ISC & PD" |
| 37 | LICENSE:${PN}-staticdev = "BSD-3-Clause & ISC & PD" |
| 38 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 39 | LIC_FILES_CHKSUM = "file://COPYING;md5=75e85c5a558f86d10fbd5abc567ea5e6" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 40 | SECTION = "libs" |
| 41 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 42 | SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 43 | file://0001-funopen-Replace-off64_t-with-off_t-in-funopen_seek.patch \ |
| 44 | " |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 45 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 46 | SRC_URI[sha256sum] = "9baa186059ebbf25c06308e9f991fda31f7183c0f24931826d83aa6abd8a0261" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 47 | |
| 48 | inherit autotools pkgconfig |
| 49 | |
| 50 | DEPENDS += "libmd" |
| 51 | |
| 52 | BBCLASSEXTEND = "native nativesdk" |