Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Userspace utilities for fs-verity" |
| 2 | DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \ |
| 3 | on-demand integrity/authenticity verification of the contents of read-only \ |
| 4 | files, using a hidden Merkle tree (hash tree) associated with the file. The \ |
| 5 | mechanism is similar to dm-verity, but implemented at the file level rather \ |
| 6 | than at the block device level." |
| 7 | HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html" |
| 8 | SECTION = "console" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220" |
| 11 | |
| 12 | SRCREV = "20e87c13075a8e5660a8d69fd6c93d4f7c5f01a5" |
| 13 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git;branch=master" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS = "openssl" |
| 18 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 19 | EXTRA_OEMAKE:append = " PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 20 | # We want to statically link the binary to libfsverity on native Windows |
| 21 | EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1" |
| 22 | EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1" |
| 23 | |
| 24 | do_install() { |
| 25 | oe_runmake install DESTDIR=${D} |
| 26 | } |
| 27 | |
| 28 | PACKAGES =+ "libfsverity" |
| 29 | FILES:libfsverity = "${libdir}/libfsverity*${SOLIBS}" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |