Vijay Khemka | 6e220b3 | 2020-08-10 12:32:14 -0700 | [diff] [blame] | 1 | SUMMARY = "Expression parser" |
| 2 | HOMEPAGE = "https://github.com/ArashPartow/exprtk" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
Arash Partow | 96afb81 | 2023-02-16 22:31:58 +1100 | [diff] [blame] | 6 | SRCREV = "f46bffcd6966d38a09023fb37ba9335214c9b959" |
Vijay Khemka | 6e220b3 | 2020-08-10 12:32:14 -0700 | [diff] [blame] | 7 | |
Arash Partow | 96afb81 | 2023-02-16 22:31:58 +1100 | [diff] [blame] | 8 | SRC_URI = "git://github.com/ArashPartow/exprtk.git;branch=release;protocol=https" |
Vijay Khemka | 6e220b3 | 2020-08-10 12:32:14 -0700 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | # other packages commonly reference the file directly as "exprtk.hpp" |
| 13 | # create symlink to allow this usage |
| 14 | do_install() { |
| 15 | install -d ${D}/${includedir} |
| 16 | install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp |
| 17 | } |
| 18 | |
| 19 | # exprtk is a header only C++ library, so the main package will be empty. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN}-dev = "" |
Vijay Khemka | 6e220b3 | 2020-08-10 12:32:14 -0700 | [diff] [blame] | 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |