Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Improved drop-in replacement for std::function" |
| 2 | DESCRIPTION = "Provides improved implementations of std::function." |
| 3 | HOMEPAGE = "https://naios.github.io/function2" |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 6 | SRCREV = "a354bd093d2b6e50c9325dbce84d20b4e77aabc6" |
| 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRC_URI += "gitsm://github.com/Naios/function2;branch=master;protocol=https" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | inherit ptest |
| 15 | |
| 16 | # Installs some data to incorrect top-level /usr directory |
| 17 | do_install:append() { |
| 18 | mkdir -p ${D}/${datadir}/function2 |
| 19 | mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/ |
| 20 | mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/ |
| 21 | } |