blob: c7f7989115856d107e7245298c29fc57937a90c5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Window navigation construction toolkit"
2LICENSE = "LGPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5BPN = "libwnck"
6
7SECTION = "x11/libs"
8DEPENDS = "cairo glib-2.0 gtk+3"
9
10PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
11PACKAGECONFIG[x11] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification libxres"
12
Andrew Geissler517393d2023-01-13 08:55:19 -060013GTKDOC_MESON_OPTION = "gtk_doc"
14GIR_MESON_ENABLE_FLAG = 'enabled'
15GIR_MESON_DISABLE_FLAG = 'disabled'
16
17inherit gnomebase gobject-introspection gtk-doc gettext features_check
18
19def gnome_verdir(v):
20 return oe.utils.trim_version(v, 1)
21
22SRC_URI[archive.sha256sum] = "905bcdb85847d6b8f8861e56b30cd6dc61eae67ecef4cd994a9f925a26a2c1fe"
23
24# gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
25# cairo would at least needed to be built with xlib.
26ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"