Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build" |
| 2 | DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \ |
| 3 | Makefile.PL file to drive distribution configuration, build, test and \ |
| 4 | installation. Traditionally, Build.PL uses Module::Build as the underlying \ |
| 5 | build system. This module provides a simple, lightweight, drop-in replacement. \ |
| 6 | Whereas Module::Build has over 6,700 lines of code; this module has less than \ |
| 7 | 120, yet supports the features needed by most distributions." |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=57b8100f0b648cd37fbc3725fe3c111a" |
| 14 | |
| 15 | DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native" |
| 16 | |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz" |
| 18 | SRC_URI[md5sum] = "2332c90c17454107fea3f2614e11a3a9" |
| 19 | SRC_URI[sha256sum] = "7d580ff6ace0cbe555bf36b86dc8ea232581530cbeaaea09bccb57b55797f11c" |
| 20 | |
| 21 | S = "${WORKDIR}/Module-Build-Tiny-${PV}" |
| 22 | |
| 23 | inherit cpan_build |
| 24 | |
| 25 | do_install () { |
| 26 | cpan_build_do_install |
| 27 | } |
| 28 | |
| 29 | RDEPENDS_${PN} = " libextutils-config-perl \ |
| 30 | libextutils-helpers-perl \ |
| 31 | libextutils-installpaths-perl \ |
| 32 | perl-module-xsloader \ |
| 33 | perl-module-file-spec \ |
| 34 | perl-module-io-handle \ |
| 35 | perl-module-tap-harness-env \ |
| 36 | perl-module-ipc-open3 \ |
| 37 | perl-module-file-path \ |
| 38 | perl-module-cpan \ |
| 39 | perl-module-extutils-cbuilder \ |
| 40 | perl-module-getopt-long \ |
| 41 | perl-module-extutils-makemaker \ |
| 42 | perl-module-exporter \ |
| 43 | perl-module-carp \ |
| 44 | perl-module-test-more \ |
| 45 | perl-module-text-parsewords \ |
| 46 | perl-module-load \ |
| 47 | perl-module-file-temp \ |
| 48 | perl-module-data-dumper \ |
| 49 | perl-module-extutils-parsexs \ |
| 50 | perl-module-pod-man \ |
| 51 | perl-module-json-pp \ |
| 52 | " |
| 53 | |
| 54 | BBCLASSEXTEND = "native" |