Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "PSF" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3" |
| 5 | |
| 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ |
| 7 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| 8 | file://remove-build-path-in-comments.patch \ |
| 9 | file://add-glibc-check.patch \ |
| 10 | ${CONFIGFILESURI} " |
| 11 | |
| 12 | CONFIGFILESURI ?= "" |
| 13 | |
| 14 | CONFIGFILESURI_aarch64 = " \ |
| 15 | file://config.h \ |
| 16 | file://_numpyconfig.h \ |
| 17 | " |
| 18 | CONFIGFILESURI_arm = " \ |
| 19 | file://config.h \ |
| 20 | file://numpyconfig.h \ |
| 21 | " |
| 22 | CONFIGFILESURI_armeb = " \ |
| 23 | file://config.h \ |
| 24 | file://numpyconfig.h \ |
| 25 | " |
| 26 | CONFIGFILESURI_mipsel = " \ |
| 27 | file://config.h \ |
| 28 | file://numpyconfig.h \ |
| 29 | " |
| 30 | CONFIGFILESURI_x86 = " \ |
| 31 | file://config.h \ |
| 32 | file://numpyconfig.h \ |
| 33 | " |
| 34 | CONFIGFILESURI_x86-64 = " \ |
| 35 | file://config.h \ |
| 36 | file://_numpyconfig.h \ |
| 37 | " |
| 38 | CONFIGFILESURI_mips = " \ |
| 39 | file://config.h \ |
| 40 | file://_numpyconfig.h \ |
| 41 | " |
| 42 | CONFIGFILESURI_powerpc = " \ |
| 43 | file://config.h \ |
| 44 | file://_numpyconfig.h \ |
| 45 | " |
| 46 | CONFIGFILESURI_powerpc64 = " \ |
| 47 | file://config.h \ |
| 48 | file://_numpyconfig.h \ |
| 49 | " |
| 50 | CONFIGFILESURI_mips64 = " \ |
| 51 | file://config.h \ |
| 52 | file://_numpyconfig.h \ |
| 53 | " |
| 54 | CONFIGFILESURI_mips64n32 = " \ |
| 55 | file://config.h \ |
| 56 | file://_numpyconfig.h \ |
| 57 | " |
| 58 | |
| 59 | S = "${WORKDIR}/numpy-${PV}" |
| 60 | |
| 61 | inherit distutils |
| 62 | |
| 63 | # Make the build fail and replace *config.h with proper one |
| 64 | # This is a ugly, ugly hack - Koen |
| 65 | do_compile_prepend_class-target() { |
| 66 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ |
| 67 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ |
| 68 | true |
| 69 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ |
| 70 | } |
| 71 | |
| 72 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" |
| 73 | |
| 74 | SRC_URI[md5sum] = "90bb9034652cefbada19cf7d141a6a61" |
| 75 | SRC_URI[sha256sum] = "f7f91842056a7cf680b0eaf8cefc5e46c69e2521e651128d2e6aaaccec8652ae" |
| 76 | |
| 77 | # install what is needed for numpy.test() |
| 78 | RDEPENDS_${PN} = "python-unittest \ |
| 79 | python-difflib \ |
| 80 | python-pprint \ |
| 81 | python-pickle \ |
| 82 | python-shell \ |
| 83 | python-nose \ |
| 84 | python-doctest \ |
| 85 | python-datetime \ |
| 86 | python-distutils \ |
| 87 | python-misc \ |
| 88 | python-mmap \ |
| 89 | python-netclient \ |
| 90 | python-numbers \ |
| 91 | python-pydoc \ |
| 92 | python-pkgutil \ |
| 93 | python-email \ |
| 94 | python-subprocess \ |
| 95 | python-compression \ |
| 96 | python-ctypes \ |
| 97 | python-threading \ |
| 98 | " |
| 99 | |
| 100 | RDEPENDS_${PN}_class-native = "" |
| 101 | |
| 102 | BBCLASSEXTEND = "native nativesdk" |