Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "U-Boot libraries and tools to access environment" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | |
| 3 | DESCRIPTION = "This package contains tools and libraries to read \ |
| 4 | and modify U-Boot environment. \ |
| 5 | It provides a hardware-independent replacement for fw_printenv/setenv utilities \ |
| 6 | provided by U-Boot" |
| 7 | |
| 8 | HOMEPAGE = "https://github.com/sbabic/libubootenv" |
| 9 | LICENSE = "LGPL-2.1" |
| 10 | LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c" |
| 11 | SECTION = "libs" |
| 12 | |
| 13 | PV = "0.2+git${SRCPV}" |
| 14 | SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https" |
| 15 | SRCREV = "f4b9cde3815abe84a98079cedd515283ea08c16b" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit cmake lib_package |
| 20 | |
| 21 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release" |
| 22 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 23 | DEPENDS = "zlib" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | PROVIDES += "u-boot-fw-utils" |
| 25 | RPROVIDES_${PN}-bin += "u-boot-fw-utils" |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |