Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Very fast, header only, C++ logging library." |
| 2 | HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 6 | SRCREV = "7e635fca68d014934b4af8a1cf874f63989352b7" |
| 7 | SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | |
| 9 | DEPENDS += "fmt" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | BBCLASSEXTEND = "native" |
| 14 | # no need to build example & tests & benchmarks on pure yocto |
| 15 | EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on" |
| 16 | |
| 17 | inherit cmake |