blob: c7d8ff8f3d64aa103b5aaca8358dd9866e8c4c86 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
Andrew Geissler8f840682023-07-21 09:09:43 -05006SRCREV = "7e635fca68d014934b4af8a1cf874f63989352b7"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9DEPENDS += "fmt"
10
11S = "${WORKDIR}/git"
12
13BBCLASSEXTEND = "native"
14# no need to build example & tests & benchmarks on pure yocto
15EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
16
17inherit cmake