Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Linear Algebra PACKage" |
| 2 | URL = "http://www.netlib.org/lapack" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40" |
| 5 | |
| 6 | # Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended) |
| 7 | # Enabling FORTRAN |
| 8 | # Note this is not officially supported and is just illustrated here to |
| 9 | # show an example of how it can be done |
| 10 | # You'll also need your fortran recipe to depend on libgfortran |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | #FORTRAN:forcevariable = ",fortran" |
| 12 | #RUNTIMETARGET:append:pn-gcc-runtime = " libquadmath" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS = "libgfortran" |
| 15 | |
| 16 | SRCREV = "6acc99d5f39130be7cec00fb835606042101a970" |
| 17 | SRC_URI = "git://github.com/Reference-LAPACK/lapack.git;protocol=https" |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON " |
| 21 | OECMAKE_GENERATOR = "Unix Makefiles" |
| 22 | |
| 23 | inherit cmake pkgconfig |
| 24 | EXCLUDE_FROM_WORLD = "1" |