Tim Lee | f7fc57b | 2020-06-18 09:28:26 +0800 | [diff] [blame] | 1 | SUMMARY = "Init PSU inventory" |
| 2 | DESCRIPTION = "Setup PSU inventory read from PSU" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit allarch systemd |
| 8 | |
| 9 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}" |
| 10 | RDEPENDS_${PN} += "bash" |
| 11 | |
| 12 | SYSTEMD_SERVICE_${PN} = "first-boot-set-psu@.service" |
| 13 | SYSTEMD_SERVICE_${PN} += "first-boot-set-psu@0-2-0x58.service" |
| 14 | |
| 15 | SRC_URI = "file://${BPN}.sh file://${BPN}@.service" |
| 16 | |
| 17 | S = "${WORKDIR}" |
| 18 | do_install() { |
| 19 | install -d ${D}${bindir} ${D}${systemd_system_unitdir} |
| 20 | install ${BPN}.sh ${D}${bindir}/ |
| 21 | install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/ |
| 22 | } |