Alexander Filippov | 126f667 | 2018-11-28 11:32:04 +0300 | [diff] [blame] | 1 | SUMMARY = "Init BMC MAC address" |
| 2 | DESCRIPTION = "Setup BMC MAC address read from VPD" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
Brad Bishop | 1ebdb61 | 2019-09-13 12:18:25 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Alexander Filippov | 126f667 | 2018-11-28 11:32:04 +0300 | [diff] [blame] | 6 | |
| 7 | inherit allarch systemd |
| 8 | |
| 9 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}" |
| 10 | |
| 11 | SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service" |
| 12 | |
Brad Bishop | 558caea | 2019-06-21 09:32:36 -0400 | [diff] [blame] | 13 | SRC_URI = "file://${BPN}.sh file://${BPN}@.service" |
Alexander Filippov | 126f667 | 2018-11-28 11:32:04 +0300 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | do_install() { |
| 17 | install -d ${D}${bindir} ${D}${systemd_system_unitdir} |
Brad Bishop | 558caea | 2019-06-21 09:32:36 -0400 | [diff] [blame] | 18 | install ${BPN}.sh ${D}${bindir}/ |
| 19 | install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/ |
Alexander Filippov | 126f667 | 2018-11-28 11:32:04 +0300 | [diff] [blame] | 20 | } |