Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 1 | SUMMARY = "SoftHSM is an implementation of a cryptographic store accessible through a PKCS #11 interface." |
| 2 | HOMEPAGE = "www.opendnssec.org" |
| 3 | |
| 4 | LICENSE = "BSD" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210" |
| 6 | |
| 7 | DEPENDS = "sqlite3" |
| 8 | |
| 9 | SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz" |
| 10 | SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2" |
| 11 | |
| 12 | inherit autotools pkgconfig siteinfo |
| 13 | |
| 14 | EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr" |
| 15 | EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}" |
| 16 | |
| 17 | PACKAGECONFIG ?= "pk11 openssl" |
| 18 | |
| 19 | PACKAGECONFIG[npm] = ",--disable-non-paged-memory" |
| 20 | PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc" |
| 21 | PACKAGECONFIG[gost] = "--enable-gost,--disable-gost" |
| 22 | PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa" |
| 23 | PACKAGECONFIG[fips] = "--enable-fips, --disable-fips" |
| 24 | PACKAGECONFIG[notvisable] = "--disable-visibility" |
| 25 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl" |
| 26 | PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan" |
| 27 | PACKAGECONFIG[migrate] = "--with-migrate" |
| 28 | PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit==${STAGING_DIR_HOST}/usr, --without-p11-kit, p11-kit, p11-kit" |
| 29 | |
| 30 | RDEPENDS_${PN} = "sqlite3" |