Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Package that provides access to GPIO and other IO\ |
| 2 | functions on the Broadcom BCM 2835 chip, allowing access to the\ |
| 3 | GPIO pins on the 26 pin IDE plug on the RPi board" |
| 4 | SECTION = "base" |
| 5 | HOMEPAGE = "http://www.open.com.au/mikem/bcm2835" |
| 6 | AUTHOR = "Mike McCauley (mikem@open.com.au)" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | COMPATIBLE_MACHINE = "raspberrypi" |
| 12 | |
| 13 | SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz" |
| 14 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 15 | SRC_URI[md5sum] = "258caf3437012d09a651e1852d0bd60c" |
| 16 | SRC_URI[sha256sum] = "52180b8a61b6546c1df4aed259d0a4d2fa56e50605e0d4d967a76bf2b23dafb8" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 17 | |
| 18 | inherit autotools |
| 19 | |
| 20 | do_compile_append() { |
| 21 | # Now compiling the examples provided by the package |
| 22 | mkdir -p ${B}/examples |
| 23 | for file in `ls ${S}/examples`; do |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 24 | ${CC} ${LDFLAGS} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 25 | done |
| 26 | } |
| 27 | |
| 28 | do_install_append() { |
| 29 | install -d ${D}/${libdir}/${BPN} |
| 30 | for file in ${B}/examples/* |
| 31 | do |
| 32 | install -m 0755 ${file} ${D}/${libdir}/${BPN} |
| 33 | done |
| 34 | } |
| 35 | |
| 36 | PACKAGES += "${PN}-tests" |
| 37 | |
| 38 | FILES_${PN} = "" |
| 39 | FILES_${PN}-tests = "${libdir}/${BPN}" |
| 40 | FILES_${PN}-dbg += "${libdir}/${BPN}/.debug" |