Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Gnuplot is a portable command-line driven graphing utility" |
| 2 | DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \ |
| 3 | (text or binary) and function plotting utility." |
| 4 | HOMEPAGE = "http://www.gnuplot.info/" |
| 5 | SECTION = "console/scientific" |
| 6 | LICENSE = "gnuplot" |
| 7 | LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f" |
| 8 | DEPENDS = "${BPN}-native virtual/libx11 gd readline" |
| 9 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 10 | inherit autotools features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | # depends on virtual/libx11 |
| 12 | REQUIRED_DISTRO_FEATURES = "x11" |
| 13 | |
| 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${BP}.tar.gz;name=archive \ |
| 15 | http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \ |
| 16 | file://gnuplot.desktop \ |
| 17 | file://gnuplot.png \ |
| 18 | " |
| 19 | SRC_URI_append_class-target = " \ |
| 20 | file://0002-do-not-build-demos.patch \ |
| 21 | file://0003-Use-native-tools-to-build-docs.patch \ |
| 22 | file://0004-Add-configure-option-to-find-qt5-native-tools.patch \ |
| 23 | " |
| 24 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 25 | SRC_URI[archive.md5sum] = "2df8767c7399bee57a96296d46b4d5fb" |
| 26 | SRC_URI[archive.sha256sum] = "60a6764ccf404a1668c140f11cc1f699290ab70daa1151bb58fed6139a28ac37" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6" |
| 28 | SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132" |
| 29 | |
| 30 | # for building docs (they deserve it) we need *doc2* tools native |
| 31 | BBCLASSEXTEND = "native" |
| 32 | DEPENDS_class-native = "readline-native" |
| 33 | PACKAGECONFIG_class-native = "" |
| 34 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 35 | SRC_URI_append_class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | |
| 37 | do_install_class-native() { |
| 38 | install -d ${D}${bindir} |
| 39 | install ${B}/docs/*doc* ${D}${bindir} |
| 40 | rm ${D}${bindir}/*.o |
| 41 | } |
| 42 | |
| 43 | PACKAGECONFIG ??= "cairo" |
| 44 | PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango" |
| 45 | PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua" |
| 46 | PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native" |
| 47 | |
| 48 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \ |
| 49 | --without-tutorial \ |
| 50 | --disable-wxwidgets" |
| 51 | |
| 52 | do_compile_prepend() { |
| 53 | install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/ |
| 54 | } |
| 55 | |
| 56 | do_install_append_class-target() { |
| 57 | install -d ${D}${datadir}/applications/ |
| 58 | install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/ |
| 59 | install -d ${D}${datadir}/pixmaps/ |
| 60 | install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/ |
| 61 | } |
| 62 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 63 | PACKAGES =+ "${PN}-x11" |
| 64 | |
| 65 | RPROVIDES_${PN}-dbg += "${PN}-x11-dbg" |
| 66 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 67 | DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot." |
| 68 | SECTION_${PN}-x11 = "x11/scientific" |
| 69 | FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 " |
| 70 | |
| 71 | FILES_${PN} += "${datadir}/texmf" |