Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame^] | 1 | SUMMARY = "A library to access weather information from online services" |
| 2 | |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | GNOMEBN = "libgweather" |
| 8 | S = "${WORKDIR}/${GNOMEBN}-${PV}" |
| 9 | |
| 10 | inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala features_check upstream-version-is-even |
| 11 | |
| 12 | SRC_URI[archive.sha256sum] = "440d44801b6f72b48c676e5e37f9109cfee1394fd74cc92725e1b1ba4fae834c" |
| 13 | |
| 14 | # gobject-introspection is mandatory and cannot be configured |
| 15 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 16 | GIR_MESON_OPTION = "" |
| 17 | |
| 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 19 | |
| 20 | DEPENDS = " \ |
| 21 | geocode-glib \ |
| 22 | gtk+3 \ |
| 23 | json-glib \ |
| 24 | libsoup-2.4 \ |
| 25 | python3-pygobject-native \ |
| 26 | " |
| 27 | |
| 28 | FILES:${PN} += " \ |
| 29 | ${datadir}/libgweather-4 \ |
| 30 | ${libdir}/libgweather-4 \ |
| 31 | " |