blob: 18062c8fb85ec4e87abc12a2268c987396b271c7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
7
Patrick Williams705982a2024-01-12 09:51:57 -06008SRC_URI[sha256sum] = "2cf0005922c6ace4a3e2ec8b4080eb0d9753fdc93107415332f50ce9e7994280"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009
10DEPENDS += "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi python_setuptools_build_meta
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-tomllib \
30 ${PYTHON_PN}-wcwidth \
31"
32
33ALTERNATIVE:${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"