Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5" |
| 9 | |
| 10 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| 11 | file://run-ptest \ |
| 12 | file://avoid-check-user-break-cc.patch \ |
| 13 | file://0001-aclocal.m4-add-missing-header-defines.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "b9272ec8af6257103261ec3622692991" |
| 17 | SRC_URI[sha256sum] = "7eddd53401b99b90bac3f7ebf23dd583d7d99c6106e67a4f1161b7a20110dc6f" |
| 18 | |
| 19 | S = "${WORKDIR}/diffstat-${PV}" |
| 20 | |
| 21 | inherit autotools gettext ptest |
| 22 | |
| 23 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 24 | |
| 25 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 29 | } |