Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \ |
| 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz" |
| 12 | SRC_URI[sha256sum] = "1d1010a1751d076d5291e433c138502a794d679a7498d1268ee21e2d4a140eb4" |
| 13 | |
| 14 | inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases |
| 15 | |
| 16 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 17 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 18 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 19 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 20 | |
| 21 | PACKAGECONFIG ??= "cairo freetype glib icu" |
| 22 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 23 | PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype" |
| 24 | PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0" |
| 25 | PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2" |
| 26 | PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu" |
| 27 | |
| 28 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
| 29 | |
| 30 | LEAD_SONAME = "libharfbuzz.so" |
| 31 | |
| 32 | do_install:append() { |
| 33 | # If no tools are installed due to PACKAGECONFIG then this directory might |
| 34 | # still be installed, so remove it to stop packaging warnings. |
| 35 | [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 36 | } |
| 37 | |
| 38 | FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 39 | FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 40 | ${libdir}/libharfbuzz-icu.so \ |
| 41 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 42 | " |
| 43 | FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |