Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | HOMEPAGE = "https://lttng.org/" |
| 5 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4" |
| 7 | |
| 8 | inherit module |
| 9 | |
| 10 | include lttng-platforms.inc |
| 11 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 12 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 13 | file://0009-Rename-genhd-wrapper-to-blkdev.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | file://0001-fix-mm-slab_common-drop-kmem_alloc-avoid-dereferenci.patch \ |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 15 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 17 | # Use :append here so that the patch is applied also when using devupstream |
| 18 | SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch" |
| 19 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "5a99679df7903160cbde3918fee5af90ffafc90fc96ccdefaa57cf230492b234" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 21 | |
| 22 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 23 | |
| 24 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 25 | |
| 26 | MODULES_MODULE_SYMVERS_LOCATION = "src" |
| 27 | |
| 28 | do_install:append() { |
| 29 | # Delete empty directories to avoid QA failures if no modules were built |
| 30 | if [ -d ${D}/${nonarch_base_libdir} ]; then |
| 31 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 32 | fi |
| 33 | } |
| 34 | |
| 35 | python do_package:prepend() { |
| 36 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 37 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 38 | } |
| 39 | |
| 40 | BBCLASSEXTEND = "devupstream:target" |
| 41 | SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13" |
| 42 | SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630" |
| 43 | SRCREV_FORMAT ?= "lttng_git" |