Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | SUMMARY = "Open source iec61850 implementation" |
| 2 | DESCRIPTION = "IEC 61850 is an international standard for \ |
| 3 | communication systems in Substation Automation Systems \ |
| 4 | (SAS) and management of Decentralized Energy Resources \ |
| 5 | (DER). It is seen as one of the communication standards \ |
| 6 | of the emerging Smart Grid. \ |
| 7 | The project libIEC61850 provides a server and client \ |
| 8 | library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \ |
| 9 | 61850-9-2/Sampled Values communication protocols \ |
| 10 | written in C. It is available under the GPLv3 license." |
| 11 | HOMEPAGE = "http://libiec61850.com" |
| 12 | SECTION = "console/network" |
| 13 | LICENSE = "GPLv3" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 15 | DEPENDS = "swig-native python3" |
| 16 | SRCREV = "d798814fb463115a835da597535a625b68a39cff" |
| 17 | |
| 18 | SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.4 \ |
| 19 | file://0001-use-poll.h-instead-of-sys-poll.h.patch \ |
| 20 | file://0002-serial_port_linux-Add-missing-include-sys-time.h.patch \ |
| 21 | file://0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \ |
| 22 | " |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit cmake pkgconfig python3-dir python3native siteinfo |
| 27 | |
| 28 | EXTRA_OECMAKE = " \ |
| 29 | -DBUILD_EXAMPLES=OFF \ |
| 30 | -DBUILD_PYTHON_BINDINGS=ON \ |
| 31 | " |
| 32 | |
| 33 | RDEPENDS_${PN}-python = " python3-core " |
| 34 | RDEPENDS_${PN} = " python3-core " |
| 35 | |
| 36 | FILES_${PN} += " \ |
| 37 | ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \ |
| 38 | ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \ |
| 39 | " |