blob: 88a89fb0b6a947e7028b68805ffc0520a04d0105 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008SRCREV = "b0ec7aa2ef743d113fd8c5e57c0ca3d5edd86f0e"
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRC_URI = "http://fwts.ubuntu.com/release/fwts-V19.06.00.tar.gz;subdir=${BPN}-${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010 file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
11 file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
12 file://0003-Undefine-PAGE_SIZE.patch \
13 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 file://0001-Remove-Werror-from-build.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 "
Brad Bishop26bdd442019-08-16 17:08:17 -040017SRC_URI[md5sum] = "012f933329510cc5a71817ede681eee2"
18SRC_URI[sha256sum] = "13aa991f12c69f48df368aae5e5d0fbc9136413b4bfe115421bc3216d919f8a2"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
Brad Bishop26bdd442019-08-16 17:08:17 -040022DEPENDS = "libpcre json-c glib-2.0 dtc bison-native libbsd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025inherit autotools bash-completion pkgconfig
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026
27CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028LDFLAGS_append_libc-musl = " -lexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029
30FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
31FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
32FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
33FILES_${PN}-dbg += "${libdir}/fwts/.debug"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034
35TOOLCHAIN = "gcc"
36