blob: f50e0bba1538b87d64f357ccc82544614d00cf94 [file] [log] [blame]
Delphine CC Chiu177e9872023-09-22 10:30:23 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit allarch systemd obmc-phosphor-systemd
5
6RDEPENDS:${PN} += "bash"
7RDEPENDS:${PN} += "libgpiod-tools"
8RDEPENDS:${PN} += "yosemite4-common-functions"
9
10SRC_URI += " \
11 file://yosemite4-sys-init.service \
12 file://yosemite4-early-sys-init \
Delphine CC Chiu4f0996c2024-01-11 17:44:43 +080013 file://yosemite4-schematic-init.service \
14 file://yosemite4-schematic-init \
Delphine CC Chiu177e9872023-09-22 10:30:23 +080015 "
16
17SYSTEMD_PACKAGES = "${PN}"
18SYSTEMD_SERVICE:${PN}:append = " \
19 yosemite4-sys-init.service \
Delphine CC Chiu4f0996c2024-01-11 17:44:43 +080020 yosemite4-schematic-init.service \
Delphine CC Chiu177e9872023-09-22 10:30:23 +080021 "
22
23do_install() {
24 install -d ${D}${libexecdir}
25 install -m 0755 ${WORKDIR}/yosemite4-early-sys-init ${D}${libexecdir}
Delphine CC Chiu4f0996c2024-01-11 17:44:43 +080026 install -m 0755 ${WORKDIR}/yosemite4-schematic-init ${D}${libexecdir}
Delphine CC Chiu177e9872023-09-22 10:30:23 +080027}
28