Delphine CC Chiu | 177e987 | 2023-09-22 10:30:23 +0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 3 | |
| 4 | inherit allarch systemd obmc-phosphor-systemd |
| 5 | |
| 6 | RDEPENDS:${PN} += "bash" |
| 7 | RDEPENDS:${PN} += "libgpiod-tools" |
| 8 | RDEPENDS:${PN} += "yosemite4-common-functions" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://yosemite4-sys-init.service \ |
| 12 | file://yosemite4-early-sys-init \ |
Delphine CC Chiu | 4f0996c | 2024-01-11 17:44:43 +0800 | [diff] [blame] | 13 | file://yosemite4-schematic-init.service \ |
| 14 | file://yosemite4-schematic-init \ |
Delphine CC Chiu | 177e987 | 2023-09-22 10:30:23 +0800 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SYSTEMD_PACKAGES = "${PN}" |
| 18 | SYSTEMD_SERVICE:${PN}:append = " \ |
| 19 | yosemite4-sys-init.service \ |
Delphine CC Chiu | 4f0996c | 2024-01-11 17:44:43 +0800 | [diff] [blame] | 20 | yosemite4-schematic-init.service \ |
Delphine CC Chiu | 177e987 | 2023-09-22 10:30:23 +0800 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${libexecdir} |
| 25 | install -m 0755 ${WORKDIR}/yosemite4-early-sys-init ${D}${libexecdir} |
Delphine CC Chiu | 4f0996c | 2024-01-11 17:44:43 +0800 | [diff] [blame] | 26 | install -m 0755 ${WORKDIR}/yosemite4-schematic-init ${D}${libexecdir} |
Delphine CC Chiu | 177e987 | 2023-09-22 10:30:23 +0800 | [diff] [blame] | 27 | } |
| 28 | |