William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 1 | SUMMARY = "C++11 command line parser" |
| 2 | DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface." |
| 3 | HOMEPAGE = "https://github.com/CLIUtils/CLI11" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c271fee3ae28e11b24b97284d9f82887" |
| 6 | SRCREV = "bd4dc911847d0cde7a6b41dfa626a85aab213baf" |
| 7 | PV .= "+git${SRCPV}" |
| 8 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \ |
| 10 | file://0001-Add-CLANG_TIDY-check.patch \ |
| 11 | " |
William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake |
| 16 | inherit ptest |
| 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | EXTRA_OECMAKE += "-DCLANG_TIDY=OFF" |
William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 19 | DEPENDS += "boost" |