Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM enhanced error logging" |
| 2 | DESCRIPTION = "Adds additional error logging functionality for IBM systems" |
| 3 | PR = "r1" |
Patrick Venture | 18823e6 | 2018-10-26 09:39:44 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 5 | HOMEPAGE = "https://github.com/openbmc/ibm-logging" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | SRC_URI += "git://github.com/openbmc/ibm-logging" |
Andrew Geissler | 63e9765 | 2020-04-02 21:40:25 +0000 | [diff] [blame] | 9 | SRCREV = "94924b4b106024c7a09daf3ebde8e0a33e050f3f" |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 10 | |
| 11 | inherit autotools |
| 12 | inherit pkgconfig |
Matt Spinler | 1a9ef19 | 2020-02-20 10:56:34 -0600 | [diff] [blame] | 13 | inherit python3native |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 14 | inherit obmc-phosphor-dbus-service |
| 15 | inherit obmc-phosphor-systemd |
Matt Spinler | 1739501 | 2018-03-28 14:00:19 -0500 | [diff] [blame] | 16 | inherit phosphor-dbus-yaml |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS += " \ |
| 19 | ibm-dbus-interfaces \ |
| 20 | phosphor-logging \ |
| 21 | nlohmann-json \ |
| 22 | autoconf-archive-native \ |
| 23 | sdbusplus \ |
| 24 | " |
| 25 | |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | SRC_URI += "file://policyTable.json" |
| 29 | |
| 30 | PACKAGECONFIG ??= "" |
| 31 | PACKAGECONFIG[policy-interface] = "--enable-policy-interface, --disable-policy-interface,," |
| 32 | |
Brad Bishop | e161514 | 2020-04-22 14:06:02 -0400 | [diff] [blame^] | 33 | PACKAGECONFIG_ibm-ac-server = "policy-interface" |
| 34 | PACKAGECONFIG_mihawk = "policy-interface" |
| 35 | |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 36 | SERVICE = "com.ibm.Logging.service" |
| 37 | DBUS_SERVICE_${PN} += "${SERVICE}" |
| 38 | |
| 39 | #The link is so that this service will restart if phosphor-logging restarts. |
| 40 | #The BindsTo in the service will not do the restart, it will only do the |
| 41 | #original start and a stop. |
| 42 | LOG_FMT = "../${SERVICE}:xyz.openbmc_project.Logging.service.wants/${SERVICE}" |
| 43 | SYSTEMD_LINK_${PN} += "${LOG_FMT}" |
| 44 | |
| 45 | do_install_append(){ |
| 46 | |
| 47 | install -d ${D}${datadir}/ibm-logging |
| 48 | |
| 49 | ${S}/condense_policy.py \ |
| 50 | -p ${WORKDIR}/policyTable.json \ |
| 51 | -c ${D}/${datadir}/ibm-logging/policy.json |
| 52 | } |
Matt Spinler | 1739501 | 2018-03-28 14:00:19 -0500 | [diff] [blame] | 53 | |
| 54 | #An optional task to generate a report on all of the errors |
| 55 | #created by OpenBMC, and compare these errors to what is |
| 56 | #in the error policy table |
| 57 | do_report(){ |
| 58 | |
| 59 | ${S}/create_error_reports.py \ |
| 60 | -p ${D}/${datadir}/ibm-logging/policy.json \ |
| 61 | -y ${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 62 | -e ${WORKDIR}/build/all_errors.json \ |
| 63 | -x ${WORKDIR}/build/policy_crosscheck.txt |
| 64 | |
| 65 | } |
| 66 | |
| 67 | addtask report |
| 68 | |
| 69 | #Collect all of the error YAML files into our recipe-sysroot-native dir. |
| 70 | do_report[depends] = " \ |
| 71 | ibm-logging:do_install \ |
| 72 | phosphor-logging-error-logs-native:do_populate_sysroot \ |
| 73 | phosphor-dbus-interfaces-native:do_populate_sysroot \ |
| 74 | openpower-dbus-interfaces-native:do_populate_sysroot \ |
| 75 | openpower-occ-control-native:do_populate_sysroot \ |
| 76 | openpower-debug-collector-native:do_populate_sysroot \ |
| 77 | " |