blob: 1fcb7edc03470533956508dc14c90567c250743e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Andrew Geissler72956ed2021-01-08 16:11:14 -06006inherit python3native gettext gtk-icon-cache features_check
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
12SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \
13 file://not-create-link-to-locale.patch \
14 "
Andrew Geissler72956ed2021-01-08 16:11:14 -060015SRC_URI[sha256sum] = "246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17do_configure() {
18 # special configure - no autotools...
19 ./configure --prefix=${prefix}
20}
21
22do_install() {
23 oe_runmake 'DESTDIR=${D}' install
24 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
25}
26
27FILES_${PN} += "${datadir}/metainfo"
28
29RDEPENDS_${PN} += "python3-pygobject python3-pexpect"