Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Documentation system for on-line information and printed output" |
| 2 | DESCRIPTION = "Texinfo is a documentation system that can produce both \ |
| 3 | online information and printed output from a single source file. The \ |
| 4 | GNU Project uses the Texinfo file format for most of its documentation." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/texinfo/" |
| 6 | SECTION = "console/utils" |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 9 | |
| 10 | PROVIDES_append_class-native = " texinfo-4.8-replacement-native" |
| 11 | |
| 12 | DEPENDS = "zlib ncurses texinfo-4.8-replacement-native" |
| 13 | DEPENDS_class-native = "zlib-native ncurses-native" |
| 14 | |
| 15 | TARGET_PATCH = "file://use_host_makedoc.patch \ |
| 16 | file://using-native-makeinfo.patch \ |
| 17 | " |
| 18 | TARGET_PATCH_class-native = "" |
| 19 | |
| 20 | SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \ |
| 21 | file://check-locale-h.patch \ |
| 22 | file://do-compile-native-tools.patch \ |
| 23 | ${TARGET_PATCH} \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[md5sum] = "4e9a1a591ed236003d0d4b008bf07eef" |
| 27 | SRC_URI[sha256sum] = "1f3cdeebe65fdf510f55d765ab1031b54416aa5bc2635b6a54ef9bcb2367c917" |
| 28 | |
| 29 | tex_texinfo = "texmf/tex/texinfo" |
| 30 | |
| 31 | inherit gettext autotools |
| 32 | |
| 33 | do_install_append() { |
| 34 | mkdir -p ${D}${datadir}/${tex_texinfo} |
| 35 | install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo} |
| 36 | } |
| 37 | |
| 38 | do_install_append_class-native() { |
| 39 | install -m 755 info/makedoc ${D}${bindir} |
| 40 | install -m 755 makeinfo/makeinfo ${D}${bindir} |
| 41 | } |
| 42 | |
| 43 | PACKAGES += "info info-doc" |
| 44 | |
| 45 | FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info" |
| 46 | FILES_info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \ |
| 47 | ${mandir}/man1/info.1* ${mandir}/man5/info.5* \ |
| 48 | ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*" |
| 49 | |
| 50 | FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo" |
| 51 | FILES_${PN}-doc = "${infodir}/texinfo* \ |
| 52 | ${datadir}/${tex_texinfo} \ |
| 53 | ${mandir}/man1 ${mandir}/man5" |
| 54 | |
| 55 | BBCLASSEXTEND = "native" |